CRAN Package Check Results for Package rock

Last updated on 2022-01-25 23:50:37 CET.

Flavor Version Tinstall Tcheck Ttotal Status Flags
r-devel-linux-x86_64-debian-clang 0.5.1 9.96 104.55 114.51 OK
r-devel-linux-x86_64-debian-gcc 0.5.1 8.02 78.42 86.44 OK
r-devel-linux-x86_64-fedora-clang 0.5.1 140.48 OK
r-devel-linux-x86_64-fedora-gcc 0.5.1 133.90 OK
r-devel-windows-x86_64-new-UL 0.5.1 86.00 152.00 238.00 OK
r-devel-windows-x86_64-new-TK 0.5.1 OK
r-patched-linux-x86_64 0.5.1 8.67 98.64 107.31 OK
r-release-linux-x86_64 0.5.1 6.53 103.21 109.74 OK
r-release-macos-arm64 0.5.1 OK
r-release-macos-x86_64 0.5.1 OK
r-release-windows-ix86+x86_64 0.5.1 16.00 129.00 145.00 OK
r-oldrel-macos-x86_64 0.5.1 ERROR
r-oldrel-windows-ix86+x86_64 0.5.1 15.00 132.00 147.00 ERROR

Check Details

Version: 0.5.1
Check: package dependencies
Result: NOTE
    Package suggested but not available for checking: ‘preregr’
Flavor: r-oldrel-macos-x86_64

Version: 0.5.1
Check: for unstated dependencies in examples
Result: WARN
    Warning: parse error in file 'lines':
    4: unexpected '>'
    1169: version = "0.1.0"
    1170: ) |>
     ^
Flavor: r-oldrel-macos-x86_64

Version: 0.5.1
Check: examples
Result: ERROR
    Running examples in ‘rock-Ex.R’ failed
    The error most likely occurred in:
    
    > ### Name: prereg_initialize
    > ### Title: Initialize a (pre)registration
    > ### Aliases: prereg_initialize
    >
    > ### ** Examples
    >
    > rock::prereg_initialize(
    + "preregQE_v0_93"
    + );
    Error in rock::prereg_initialize("preregQE_v0_93") :
     To work with (pre)registrations, you must have the {preregr} package installed. To install it, use:
    
     install.packages("preregr");
    Execution halted
Flavor: r-oldrel-macos-x86_64

Version: 0.5.1
Check: for unstated dependencies in examples
Result: WARN
    Warning: parse error in file 'lines':
    4: unexpected '>'
    1170: version = "0.1.0"
    1171: ) |>
     ^
Flavor: r-oldrel-windows-ix86+x86_64

Version: 0.5.1
Check: examples
Result: ERROR
    Running examples in 'rock-Ex.R' failed
    The error most likely occurred in:
    
    > ### Name: form_to_rmd_template
    > ### Title: Convert a (pre)registration form to an R Markdown template
    > ### Aliases: form_to_rmd_template
    >
    > ### ** Examples
    >
    > preregr::form_create(
    + title = "Example form",
    + version = "0.1.0"
    + ) |>
    Error: unexpected '>' in:
    " version = "0.1.0"
    ) |>"
    Execution halted
Flavor: r-oldrel-windows-ix86+x86_64