CRAN Package Check Results for Package smoothSurv

Last updated on 2023-02-06 23:55:58 CET.

Flavor Version Tinstall Tcheck Ttotal Status Flags
r-devel-linux-x86_64-debian-clang 2.5 52.34 88.57 140.91 WARN
r-devel-linux-x86_64-debian-gcc 2.5 45.28 66.66 111.94 WARN
r-devel-linux-x86_64-fedora-clang 2.5 205.00 WARN
r-devel-linux-x86_64-fedora-gcc 2.5 190.57 WARN
r-devel-windows-x86_64 2.5 76.00 140.00 216.00 WARN
r-patched-linux-x86_64 2.5 47.07 83.22 130.29 OK
r-release-linux-x86_64 2.5 46.29 86.64 132.93 OK
r-release-macos-arm64 2.5 57.00 OK
r-release-macos-x86_64 2.5 68.00 OK
r-release-windows-x86_64 2.5 79.00 144.00 223.00 OK
r-oldrel-macos-arm64 2.5 57.00 OK
r-oldrel-macos-x86_64 2.5 73.00 OK
r-oldrel-windows-ix86+x86_64 2.5 116.00 153.00 269.00 OK

Check Details

Version: 2.5
Check: whether package can be installed
Result: WARN
    Found the following significant warnings:
     ./Scythe_Matrix_Iterator.h:192:17: warning: 'iterator<std::random_access_iterator_tag, bool>' is deprecated [-Wdeprecated-declarations]
     ./Scythe_Matrix_Iterator.h:192:17: warning: 'iterator<std::random_access_iterator_tag, double>' is deprecated [-Wdeprecated-declarations]
     ./Scythe_Matrix_Iterator.h:73:17: warning: 'iterator<std::random_access_iterator_tag, double>' is deprecated [-Wdeprecated-declarations]
     ./Scythe_Matrix_Iterator.h:73:17: warning: 'iterator<std::random_access_iterator_tag, int>' is deprecated [-Wdeprecated-declarations]
     ./Scythe_Matrix_Iterator.h:192:17: warning: 'iterator<std::random_access_iterator_tag, int>' is deprecated [-Wdeprecated-declarations]
    See ‘/home/hornik/tmp/R.check/r-devel-clang/Work/PKGS/smoothSurv.Rcheck/00install.out’ for details.
    * used C++ compiler: ‘Debian clang version 15.0.6’
Flavor: r-devel-linux-x86_64-debian-clang

Version: 2.5
Check: whether package can be installed
Result: WARN
    Found the following significant warnings:
     Scythe_Matrix_Iterator.h:73:31: warning: ‘template<class _Category, class _Tp, class _Distance, class _Pointer, class _Reference> struct std::iterator’ is deprecated [-Wdeprecated-declarations]
     Scythe_Matrix_Iterator.h:192:31: warning: ‘template<class _Category, class _Tp, class _Distance, class _Pointer, class _Reference> struct std::iterator’ is deprecated [-Wdeprecated-declarations]
    See ‘/home/hornik/tmp/R.check/r-devel-gcc/Work/PKGS/smoothSurv.Rcheck/00install.out’ for details.
    * used C++ compiler: ‘g++-12 (Debian 12.2.0-14) 12.2.0’
Flavor: r-devel-linux-x86_64-debian-gcc

Version: 2.5
Check: whether package can be installed
Result: WARN
    Found the following significant warnings:
     ./Scythe_Matrix_Iterator.h:192:17: warning: 'iterator<std::random_access_iterator_tag, bool>' is deprecated [-Wdeprecated-declarations]
     ./Scythe_Matrix_Iterator.h:192:17: warning: 'iterator<std::random_access_iterator_tag, double>' is deprecated [-Wdeprecated-declarations]
     ./Scythe_Matrix_Iterator.h:73:17: warning: 'iterator<std::random_access_iterator_tag, double>' is deprecated [-Wdeprecated-declarations]
     ./Scythe_Matrix_Iterator.h:73:17: warning: 'iterator<std::random_access_iterator_tag, int>' is deprecated [-Wdeprecated-declarations]
     ./Scythe_Matrix_Iterator.h:192:17: warning: 'iterator<std::random_access_iterator_tag, int>' is deprecated [-Wdeprecated-declarations]
    See ‘/data/gannet/ripley/R/packages/tests-clang/smoothSurv.Rcheck/00install.out’ for details.
    * used C++ compiler: ‘clang version 15.0.7’
Flavor: r-devel-linux-x86_64-fedora-clang

Version: 2.5
Check: whether package can be installed
Result: WARN
    Found the following significant warnings:
     Scythe_Matrix_Iterator.h:73:31: warning: ‘template<class _Category, class _Tp, class _Distance, class _Pointer, class _Reference> struct std::iterator’ is deprecated [-Wdeprecated-declarations]
     Scythe_Matrix_Iterator.h:192:31: warning: ‘template<class _Category, class _Tp, class _Distance, class _Pointer, class _Reference> struct std::iterator’ is deprecated [-Wdeprecated-declarations]
    See ‘/data/gannet/ripley/R/packages/tests-devel/smoothSurv.Rcheck/00install.out’ for details.
    * used C++ compiler: ‘g++ (GCC) 12.2.1 20221121 (Red Hat 12.2.1-4)’
Flavor: r-devel-linux-x86_64-fedora-gcc

Version: 2.5
Check: whether package can be installed
Result: WARN
    Found the following significant warnings:
     Scythe_Matrix_Iterator.h:73:31: warning: 'template<class _Category, class _Tp, class _Distance, class _Pointer, class _Reference> struct std::iterator' is deprecated [-Wdeprecated-declarations]
     Scythe_Matrix_Iterator.h:192:31: warning: 'template<class _Category, class _Tp, class _Distance, class _Pointer, class _Reference> struct std::iterator' is deprecated [-Wdeprecated-declarations]
    See 'd:/Rcompile/CRANpkg/local/4.3/smoothSurv.Rcheck/00install.out' for details.
    * used C++ compiler: 'g++.exe (GCC) 12.2.0'
Flavor: r-devel-windows-x86_64