CRAN Package Check Results for Package sentopics

Last updated on 2024-06-14 00:53:58 CEST.

Flavor Version Tinstall Tcheck Ttotal Status Flags
r-devel-linux-x86_64-debian-clang 0.7.3 88.58 427.87 516.45 OK
r-devel-linux-x86_64-debian-gcc 0.7.3 61.05 212.90 273.95 ERROR
r-devel-linux-x86_64-fedora-clang 0.7.3 598.88 NOTE
r-devel-linux-x86_64-fedora-gcc 0.7.3 634.47 NOTE
r-devel-windows-x86_64 0.7.3 71.00 334.00 405.00 OK
r-patched-linux-x86_64 0.7.3 78.72 471.23 549.95 OK
r-release-linux-x86_64 0.7.3 81.53 500.27 581.80 OK
r-release-macos-arm64 0.7.3 201.00 NOTE
r-release-macos-x86_64 0.7.3 255.00 NOTE
r-release-windows-x86_64 0.7.3 72.00 339.00 411.00 OK
r-oldrel-macos-arm64 0.7.3 189.00 NOTE
r-oldrel-macos-x86_64 0.7.3 386.00 NOTE
r-oldrel-windows-x86_64 0.7.3 86.00 420.00 506.00 OK

Check Details

Version: 0.7.3
Check: package dependencies
Result: NOTE Packages suggested but not available for checking: 'ggplot2', 'ggridges', 'plotly', 'progress', 'testthat', 'stm', 'seededlda', 'keyATM', 'stringr', 'sentometrics' Flavor: r-devel-linux-x86_64-debian-gcc

Version: 0.7.3
Check: examples
Result: ERROR Running examples in ‘sentopics-Ex.R’ failed The error most likely occurred in: > base::assign(".ptime", proc.time(), pos = "CheckExEnv") > ### Name: plot.sentopicmodel > ### Title: Plot a topic model using Plotly > ### Aliases: plot.sentopicmodel > > ### ** Examples > > lda <- LDA(ECB_press_conferences_tokens) > lda <- fit(lda, 100) 0% 10 20 30 40 50 60 70 80 90 100% [----|----|----|----|----|----|----|----|----|----| **************************************************| > plot(lda, nWords = 5) Error in plot.sentopicmodel(lda, nWords = 5) : Suggested packages are missing for the plot.sentopicmodel function. Please install first the following packages: plotly. Install command: install.packages('plotly') Calls: plot -> plot.sentopicmodel Execution halted Examples with CPU (user + system) or elapsed time > 5s user system elapsed LDAvis 4.975 0.067 5.225 chainsScores 2.280 0.091 9.983 fit.sentopicmodel 2.130 0.053 8.743 Flavor: r-devel-linux-x86_64-debian-gcc

Version: 0.7.3
Check: tests
Result: ERROR Running ‘testthat.R’ [0s/1s] Running the tests in ‘tests/testthat.R’ failed. Complete output: > > library("testthat") Error in library("testthat") : there is no package called 'testthat' Execution halted Flavor: r-devel-linux-x86_64-debian-gcc

Version: 0.7.3
Check: re-building of vignette outputs
Result: ERROR Error(s) in re-building vignettes: ... --- re-building ‘Basic_usage.Rmd’ using rmarkdown 0% 10 20 30 40 50 60 70 80 90 100% [----|----|----|----|----|----|----|----|----|----| **************************************************| Quitting from lines 87-92 [unnamed-chunk-7] (Basic_usage.Rmd) Error: processing vignette 'Basic_usage.Rmd' failed with diagnostics: Suggested packages are missing for the plot output. Please install first the following packages: ggplot2. Install command: install.packages('ggplot2') --- failed re-building ‘Basic_usage.Rmd’ --- re-building ‘Topical_time_series.Rmd’ using rmarkdown ** Processing: /home/hornik/tmp/R.check/r-devel-gcc/Work/PKGS/sentopics.Rcheck/vign_test/sentopics/vignettes/Topical_time_series_files/figure-html/unnamed-chunk-3-1.png 672x384 pixels, 8 bits/pixel, 256 colors in palette Reducing image to 8 bits/pixel, grayscale Input IDAT size = 23100 bytes Input file size = 23982 bytes Trying: zc = 9 zm = 8 zs = 0 f = 0 IDAT size = 21461 zc = 9 zm = 8 zs = 1 f = 0 zc = 1 zm = 8 zs = 2 f = 0 zc = 9 zm = 8 zs = 3 f = 0 zc = 9 zm = 8 zs = 0 f = 5 IDAT size = 19426 zc = 9 zm = 8 zs = 1 f = 5 zc = 1 zm = 8 zs = 2 f = 5 zc = 9 zm = 8 zs = 3 f = 5 Selecting parameters: zc = 9 zm = 8 zs = 0 f = 5 IDAT size = 19426 Output IDAT size = 19426 bytes (3674 bytes decrease) Output file size = 19504 bytes (4478 bytes = 18.67% decrease) 0% 10 20 30 40 50 60 70 80 90 100% [----|----|----|----|----|----|----|----|----|----| **************************************************| Quitting from lines 103-104 [unnamed-chunk-10] (Topical_time_series.Rmd) Error: processing vignette 'Topical_time_series.Rmd' failed with diagnostics: Suggested packages are missing for the sentiment_breakdown function. Please install first the following packages: ggplot2. Install command: install.packages('ggplot2') --- failed re-building ‘Topical_time_series.Rmd’ SUMMARY: processing the following files failed: ‘Basic_usage.Rmd’ ‘Topical_time_series.Rmd’ Error: Vignette re-building failed. Execution halted Flavor: r-devel-linux-x86_64-debian-gcc

Version: 0.7.3
Check: Rd cross-references
Result: NOTE Undeclared package ‘lexicon’ in Rd xrefs Flavor: r-devel-linux-x86_64-fedora-clang

Version: 0.7.3
Check: data for non-ASCII characters
Result: NOTE Note: found 3128 marked UTF-8 strings Flavors: r-devel-linux-x86_64-fedora-clang, r-devel-linux-x86_64-fedora-gcc

Version: 0.7.3
Check: installed package size
Result: NOTE installed size is 6.3Mb sub-directories of 1Mb or more: data 1.2Mb libs 4.3Mb Flavors: r-release-macos-arm64, r-release-macos-x86_64, r-oldrel-macos-arm64, r-oldrel-macos-x86_64