CRAN Package Check Results for Package rgl

Last updated on 2019-08-18 23:47:43 CEST.

Flavor Version Tinstall Tcheck Ttotal Status Flags
r-devel-linux-x86_64-debian-clang 0.100.26 60.60 186.74 247.34 OK
r-devel-linux-x86_64-debian-gcc 0.100.26 43.93 138.98 182.91 OK
r-devel-linux-x86_64-fedora-clang 0.100.26 338.39 WARN
r-devel-linux-x86_64-fedora-gcc 0.100.26 315.56 OK
r-devel-windows-ix86+x86_64 0.100.26 327.00 280.00 607.00 NOTE
r-patched-linux-x86_64 0.100.26 48.53 183.60 232.13 OK
r-patched-solaris-x86 0.100.26 392.80 WARN
r-release-linux-x86_64 0.100.26 52.19 184.43 236.62 OK
r-release-windows-ix86+x86_64 0.100.26 211.00 237.00 448.00 NOTE
r-release-osx-x86_64 0.100.26 WARN
r-oldrel-windows-ix86+x86_64 0.100.26 294.00 319.00 613.00 NOTE
r-oldrel-osx-x86_64 0.100.26 WARN

Check Details

Version: 0.100.26
Check: whether package can be installed
Result: WARN
    Found the following significant warnings:
     scene.cpp:104:27: warning: 'ptr_fun<rgl::SceneNode *, int, bool>' is deprecated [-Wdeprecated-declarations]
     scene.cpp:104:14: warning: 'bind2nd<std::__1::pointer_to_binary_function<rgl::SceneNode *, int, bool>, int>' is deprecated [-Wdeprecated-declarations]
     subscene.cpp:172:26: warning: 'ptr_fun<rgl::SceneNode *, int, bool>' is deprecated [-Wdeprecated-declarations]
     subscene.cpp:172:13: warning: 'bind2nd<std::__1::pointer_to_binary_function<rgl::SceneNode *, int, bool>, int>' is deprecated [-Wdeprecated-declarations]
     subscene.cpp:179:54: warning: 'ptr_fun<rgl::SceneNode *, int, bool>' is deprecated [-Wdeprecated-declarations]
     subscene.cpp:179:41: warning: 'bind2nd<std::__1::pointer_to_binary_function<rgl::SceneNode *, int, bool>, int>' is deprecated [-Wdeprecated-declarations]
     subscene.cpp:182:40: warning: 'ptr_fun<rgl::SceneNode *, int, bool>' is deprecated [-Wdeprecated-declarations]
     subscene.cpp:182:27: warning: 'bind2nd<std::__1::pointer_to_binary_function<rgl::SceneNode *, int, bool>, int>' is deprecated [-Wdeprecated-declarations]
     subscene.cpp:185:44: warning: 'ptr_fun<rgl::SceneNode *, int, bool>' is deprecated [-Wdeprecated-declarations]
     subscene.cpp:185:31: warning: 'bind2nd<std::__1::pointer_to_binary_function<rgl::SceneNode *, int, bool>, int>' is deprecated [-Wdeprecated-declarations]
     subscene.cpp:193:47: warning: 'ptr_fun<rgl::SceneNode *, int, bool>' is deprecated [-Wdeprecated-declarations]
     subscene.cpp:193:34: warning: 'bind2nd<std::__1::pointer_to_binary_function<rgl::SceneNode *, int, bool>, int>' is deprecated [-Wdeprecated-declarations]
Flavor: r-devel-linux-x86_64-fedora-clang

Version: 0.100.26
Check: installed package size
Result: NOTE
     installed size is 10.0Mb
     sub-directories of 1Mb or more:
     doc 3.6Mb
     fonts 1.5Mb
     libs 2.5Mb
Flavors: r-devel-linux-x86_64-fedora-clang, r-devel-windows-ix86+x86_64, r-patched-solaris-x86, r-release-windows-ix86+x86_64, r-release-osx-x86_64, r-oldrel-windows-ix86+x86_64, r-oldrel-osx-x86_64

Version: 0.100.26
Check: re-building of vignette outputs
Result: WARN
    Error(s) in re-building vignettes:
     ...
    --- re-building ‘WebGL.Rmd’ using rmarkdown
    Warning in engine$weave(file, quiet = quiet, encoding = enc) :
     Pandoc (>= 1.12.3) and/or pandoc-citeproc not available. Falling back to R Markdown v1.
    Quitting from lines 17-19 (WebGL.Rmd)
    Error: processing vignette 'WebGL.Rmd' failed with diagnostics:
    These vignettes assume pandoc version 1.14; older versions may not work.
    --- failed re-building ‘WebGL.Rmd’
    
    --- re-building ‘legacyWebGL.Rmd’ using rmarkdown
    Warning in engine$weave(file, quiet = quiet, encoding = enc) :
     Pandoc (>= 1.12.3) and/or pandoc-citeproc not available. Falling back to R Markdown v1.
    Quitting from lines 17-19 (legacyWebGL.Rmd)
    Error: processing vignette 'legacyWebGL.Rmd' failed with diagnostics:
    These vignettes assume pandoc version 1.14; older versions may not work.
    --- failed re-building ‘legacyWebGL.Rmd’
    
    --- re-building ‘rgl.Rmd’ using rmarkdown
    Warning in engine$weave(file, quiet = quiet, encoding = enc) :
     Pandoc (>= 1.12.3) and/or pandoc-citeproc not available. Falling back to R Markdown v1.
    Quitting from lines 16-19 (rgl.Rmd)
    Error: processing vignette 'rgl.Rmd' failed with diagnostics:
    These vignettes assume pandoc version 1.14; older versions may not work.
    --- failed re-building ‘rgl.Rmd’
    
    SUMMARY: processing the following files failed:
     ‘WebGL.Rmd’ ‘legacyWebGL.Rmd’ ‘rgl.Rmd’
    
    Error: Vignette re-building failed.
    Execution halted
Flavor: r-patched-solaris-x86

Version: 0.100.26
Check: re-building of vignette outputs
Result: WARN
    Error(s) in re-building vignettes:
    --- re-building ‘WebGL.Rmd’ using rmarkdown
    Warning in engine$weave(file, quiet = quiet, encoding = enc) :
     Pandoc (>= 1.12.3) and/or pandoc-citeproc not available. Falling back to R Markdown v1.
    Quitting from lines 17-19 (WebGL.Rmd)
    Error: processing vignette 'WebGL.Rmd' failed with diagnostics:
    These vignettes assume pandoc version 1.14; older versions may not work.
    --- failed re-building ‘WebGL.Rmd’
    
    --- re-building ‘legacyWebGL.Rmd’ using rmarkdown
    Warning in engine$weave(file, quiet = quiet, encoding = enc) :
     Pandoc (>= 1.12.3) and/or pandoc-citeproc not available. Falling back to R Markdown v1.
    Quitting from lines 17-19 (legacyWebGL.Rmd)
    Error: processing vignette 'legacyWebGL.Rmd' failed with diagnostics:
    These vignettes assume pandoc version 1.14; older versions may not work.
    --- failed re-building ‘legacyWebGL.Rmd’
    
    --- re-building ‘rgl.Rmd’ using rmarkdown
    Warning in engine$weave(file, quiet = quiet, encoding = enc) :
     Pandoc (>= 1.12.3) and/or pandoc-citeproc not available. Falling back to R Markdown v1.
    Quitting from lines 16-19 (rgl.Rmd)
    Error: processing vignette 'rgl.Rmd' failed with diagnostics:
    These vignettes assume pandoc version 1.14; older versions may not work.
    --- failed re-building ‘rgl.Rmd’
    
    SUMMARY: processing the following files failed:
     ‘WebGL.Rmd’ ‘legacyWebGL.Rmd’ ‘rgl.Rmd’
    
    Error: Vignette re-building failed.
    Execution halted
Flavor: r-release-osx-x86_64

Version: 0.100.26
Check: re-building of vignette outputs
Result: WARN
    Error in re-building vignettes:
     ...
    Warning in engine$weave(file, quiet = quiet, encoding = enc) :
     Pandoc (>= 1.12.3) and/or pandoc-citeproc not available. Falling back to R Markdown v1.
    Quitting from lines 17-19 (WebGL.Rmd)
    Error: processing vignette 'WebGL.Rmd' failed with diagnostics:
    These vignettes assume pandoc version 1.14; older versions may not work.
    Execution halted
Flavor: r-oldrel-osx-x86_64