CRAN Package Check Results for Package oppr

Last updated on 2022-05-27 23:54:51 CEST.

Flavor Version Tinstall Tcheck Ttotal Status Flags
r-devel-linux-x86_64-debian-clang 1.0.3 248.59 183.35 431.94 WARN
r-devel-linux-x86_64-debian-gcc 1.0.3 202.77 139.21 341.98 NOTE
r-devel-linux-x86_64-fedora-clang 1.0.3 629.05 WARN
r-devel-linux-x86_64-fedora-gcc 1.0.3 533.17 NOTE
r-devel-windows-x86_64 1.0.3 233.00 241.00 474.00 NOTE
r-patched-linux-x86_64 1.0.3 214.60 175.06 389.66 NOTE
r-release-linux-x86_64 1.0.3 212.16 175.00 387.16 NOTE
r-release-macos-arm64 1.0.3 121.00 NOTE
r-release-macos-x86_64 1.0.3 193.00 NOTE
r-release-windows-x86_64 1.0.3 241.00 236.00 477.00 NOTE
r-oldrel-macos-arm64 1.0.3 166.00 NOTE
r-oldrel-macos-x86_64 1.0.3 179.00 NOTE
r-oldrel-windows-ix86+x86_64 1.0.3 603.00 310.00 913.00 NOTE

Additional issues

clang14

Check Details

Version: 1.0.3
Check: package dependencies
Result: NOTE
    Package suggested but not available for checking: 'gurobi'
Flavors: r-devel-linux-x86_64-debian-clang, r-devel-linux-x86_64-debian-gcc, r-devel-linux-x86_64-fedora-clang, r-devel-linux-x86_64-fedora-gcc, r-devel-windows-x86_64, r-patched-linux-x86_64, r-release-linux-x86_64, r-release-macos-x86_64, r-release-windows-x86_64, r-oldrel-windows-ix86+x86_64

Version: 1.0.3
Check: whether package can be installed
Result: WARN
    Found the following significant warnings:
     functions.cpp:103:13: warning: use of bitwise '&' with boolean operands [-Wbitwise-instead-of-logical]
     rcpp_funded_projects.cpp:18:13: warning: use of bitwise '&' with boolean operands [-Wbitwise-instead-of-logical]
     rcpp_random_solution.cpp:90:11: warning: use of bitwise '|' with boolean operands [-Wbitwise-instead-of-logical]
Flavors: r-devel-linux-x86_64-debian-clang, r-devel-linux-x86_64-fedora-clang

Version: 1.0.3
Check: installed package size
Result: NOTE
     installed size is 7.0Mb
     sub-directories of 1Mb or more:
     libs 5.3Mb
Flavors: r-devel-linux-x86_64-fedora-clang, r-release-macos-arm64, r-release-macos-x86_64, r-oldrel-macos-arm64, r-oldrel-macos-x86_64

Version: 1.0.3
Check: package dependencies
Result: NOTE
    Packages suggested but not available for checking:
     'gurobi', 'ggtree', 'lpsymphony'
Flavors: r-release-macos-arm64, r-oldrel-macos-x86_64

Version: 1.0.3
Check: Rd cross-references
Result: NOTE
    Package unavailable to check Rd xrefs: ‘ggtree’
Flavors: r-release-macos-arm64, r-oldrel-macos-arm64, r-oldrel-macos-x86_64

Version: 1.0.3
Check: package dependencies
Result: NOTE
    Packages suggested but not available for checking:
     'gurobi', 'ggtree', 'Rsymphony', 'lpsymphony'
Flavor: r-oldrel-macos-arm64