CRAN Package Check Results for Package modeltime

Last updated on 2024-07-13 00:55:31 CEST.

Flavor Version Tinstall Tcheck Ttotal Status Flags
r-devel-linux-x86_64-debian-clang 1.2.8 27.20 291.51 318.71 OK
r-devel-linux-x86_64-debian-gcc 1.2.8 20.32 209.93 230.25 OK
r-devel-linux-x86_64-fedora-clang 1.2.8 390.36 NOTE
r-devel-linux-x86_64-fedora-gcc 1.2.8 388.27 NOTE
r-devel-windows-x86_64 1.2.8 22.00 233.00 255.00 NOTE
r-patched-linux-x86_64 1.2.8 1.27 2.14 3.41 ERROR
r-release-linux-x86_64 1.2.8 14.85 278.82 293.67 OK
r-release-macos-arm64 1.2.8 102.00 OK
r-release-macos-x86_64 1.2.8 200.00 OK
r-release-windows-x86_64 1.2.8 20.00 241.00 261.00 OK
r-oldrel-macos-arm64 1.2.8 112.00 OK
r-oldrel-macos-x86_64 1.2.8 214.00 OK
r-oldrel-windows-x86_64 1.2.8 30.00 310.00 340.00 OK

Check Details

Version: 1.2.8
Check: package dependencies
Result: NOTE Imports includes 31 non-default packages. Importing from so many packages makes the package vulnerable to any of them becoming unavailable. Move as many as possible to Suggests and use conditionally. Flavor: r-devel-linux-x86_64-fedora-clang

Version: 1.2.8
Check: dependencies in R code
Result: NOTE Namespaces in Imports field not imported from: ‘tidymodels’ ‘tidyverse’ All declared Imports should be used. Flavors: r-devel-linux-x86_64-fedora-clang, r-devel-linux-x86_64-fedora-gcc

Version: 1.2.8
Check: Rd cross-references
Result: NOTE Found the following Rd file(s) with Rd \link{} targets missing package anchors: adam_reg.Rd: fit.model_spec, set_engine arima_boost.Rd: fit.model_spec, set_engine arima_reg.Rd: fit.model_spec, set_engine exp_smoothing.Rd: fit.model_spec, set_engine metric_sets.Rd: metric_set, mae, mape, mase, smape, rmse, rsq modeltime_accuracy.Rd: mae, mape, mase, smape, rmse, rsq modeltime_calibrate.Rd: fit.workflow, fit.model_spec naive_reg.Rd: fit.model_spec, set_engine nnetar_reg.Rd: fit.model_spec, set_engine plot_modeltime_forecast.Rd: plot_time_series plot_modeltime_residuals.Rd: plot_time_series, plot_acf_diagnostics, plot_seasonal_diagnostics prophet_boost.Rd: fit.model_spec, set_engine prophet_reg.Rd: fit.model_spec, set_engine seasonal_reg.Rd: fit.model_spec, set_engine temporal_hierarchy.Rd: fit.model_spec, set_engine window_reg.Rd: fit.model_spec, set_engine Please provide package anchors for all Rd \link{} targets not in the package itself and the base packages. Flavor: r-devel-windows-x86_64

Version: 1.2.8
Check: package dependencies
Result: ERROR Package required but not available: ‘prophet’ See section ‘The DESCRIPTION file’ in the ‘Writing R Extensions’ manual. Flavor: r-patched-linux-x86_64